2016长城信息杯中国大学生程序设计竞赛中南邀请赛 xtu 1249 Rolling Variance

https://i-blog.csdnimg.cn/blog_migrate/88367cc169c2fef112f3e7579b6a9663.png

Bobo learnt that the variance of a sequence a1,a2,,an is

ni=1(aia¯)2n1

where

a¯=ni=1ain.


Bobo has a sequence a1,a2,,an , and he would like to find the variance of each consecutive subsequences of length m . Formally, the i -th ( 1inm+1 ) rolling variance ri is the variance of sequence {ai,ai+1,,ai+m1} .

Input

The input contains at most 30 sets. For each set:

The first line contains 2 integers n,m (2mn105) .

The second line contains n integers a1,a2,,an ( |ai|100 ).

Output

For each set, (nm+1) lines with floating numbers r1,r2,,rnm+1 .

Your answer will be considered correct if its absolute or relative error does not exceed 104 .

Sample Input

3 2
1 3 2
5 3
1 3 2 4 5

Sample Output

1.41421356
0.70710678
1.00000000
1.00000000
1.52752523

(a-b)^2=a^2-2ab+b^2拆开后有

a1^2+a2^2+a3^2+....-2*ave*(a1+a2+a3+.......)+n*ave^2

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
 
int main()
{
    int n,m;
    double ave;
    int sum[100005],a[100005],pf[100005];
    pf[0]=0;
    while(~scanf("%d %d",&n,&m))
    {
        scanf("%d",&a[1]);
        pf[1]=sum[1]=a[1];
        pf[1]*=pf[1];
        for(int i=2;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];
            pf[i]=pf[i-1]+a[i]*a[i];
        }
        for(int i=m;i<=n;i++)
        {
            ave=1.0*(sum[i]-sum[i-m])/m;
           // printf("%d %d %lf\n",pf[i]-pf[i-m],sum[i]-sum[i-m],m*ave*ave);
            printf("%.8lf\n",sqrt(  (pf[i]-pf[i-m]-2*ave*(sum[i]-sum[i-m] )+m*ave*ave) /(m-1) ));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值