2016长城信息杯中国大学生程序设计竞赛中南邀请赛 xtu 1245 Hamiltonian Path

32 篇文章 0 订阅

https://i-blog.csdnimg.cn/blog_migrate/c2e146bf6dfb26cc009c356f5ce25183.png

In ICPCCamp, there are n cities and m directed roads between cities. The i -th road going from the ai -th city to the bi -th city is ci kilometers long. For each pair of cities (u,v) , there can be more than one roads from u to v .

Bobo wants to make big news by solving the famous Hamiltonian Path problem. That is, he would like to visit all the n cities one by one so that the total distance travelled is minimized.

Formally, Bobo likes to find n distinct integers p1,p2,,pn to minimize w(p1,p2)+w(p2,p3)++w(pn1,pn) where w(x,y) is the length of road from the x -th city to the y -th city.

Input

The input contains at most 30 sets. For each set:

The first line contains 2 integers n,m ( 2n105,0m105 ).

The i -th of the following m lines contains 3 integers ai,bi,c        i 1ai<bin,1ci104 ).

Output

For each set, an integer denotes the minimum total distance. If there exists no plan, output -1 instead.

Sample Input

3 3
1 2 1
1 3 1
2 3 1
3 2
1 2 1
1 3 2

Sample Output

2
-1

首先 题目是求某人想遍历n个点所需要的时间最少 刚开始以为是最小生成树~~~然后看一下题意,看清楚,就是求w(p1,p2)+w(p2,p3)....然后输入的是有向图,ai<bi就是说不能回去了 尼玛。。所以你想遍历所有图 只能从1去2去3...如果有一处断了 输出-1 好吧 大水题 比赛的时候题目都没看  英语爆炸

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<string.h>
using namespace std;
 
int main()
{
    int t,n,m,a,b,c;
    int d[100005];
    long long ans;
    while(~scanf("%d %d",&n,&m))
    {
        memset(d,0x3f,sizeof d);
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            if(a==b-1)
                d[a]=min(d[a],c);
        }
        t=1;
        ans=0;
        for(int i=1;i<n;i++)
        {
            if(d[i]==0x3f3f3f3f)
            {
                t=0;break;
            }
            ans+=d[i];
        }
        if(!t) printf("-1\n");
        else printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值