POJ 3041 Asteroids

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10869 Accepted: 5882

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

    这道题目我知道是二分图匹配的问题,看到网上的差不多都是用的匈牙利算法,那个算法我也不会,但是我会最大流的EK算法,算法导论上说最大二分图匹配就是边上的容量为1的时候求的最大流,时间复杂度就是O(VE),看了看点个边对于这个题目不会超时,就打算用这个方法做,但是我不会建图,想了很久尝试了很多方法,发现都不合适,看到网上说一个点集由X组成,而另一个由Y组成,我不懂这是为什么,于是尝试其他方法建图,当我发现其他的方法都不合适的时候,就想了想这种,画了画图,我发现这种方法是可以的,用KM算法写了写这题过了
#include <iostream>
#include <string.h>
using namespace std;
int a[1520][1520],pre[1520],sta,end,n;
int main()
{
    int KM();
    int i,j,m,s,t,x,y;
    cin>>n>>m;
    sta=0; end=2*n+1;
    memset(a,0,sizeof(a));
    for(i=1;i<=m;i++)
    {
        cin>>x>>y;
        a[0][x]=1; a[n+y][2*n+1]=1;
        a[x][n+y]=1;
    }
    t=KM();
    cout<<t<<endl;
    return 0;
}
int bfs()
{
    int queue[100000],base,top,i,j,x;
    base=top=0;
    memset(pre,-1,sizeof(pre));
    queue[top++]=sta;
    pre[sta]=-2;
    while(base<top)
    {
        x=queue[base++];
        for(i=1;i<=2*n+1;i++)
        {
            if(pre[i]==-1&&a[x][i])
            {
                pre[i]=x;
                queue[top++]=i;
                if(i==end)
                {
                    break;
                }
            }
        }
        if(i!=2*n+2)
        {
            break;
        }
    }
    if(pre[end]==-1)
    {
        return -1;
    }
    return 1;
}
int KM()
{
    int i,j,k,sum,t,pre_x;
    sum=0;
    while(1)
    {
        k=bfs();
        if(k==-1)
        {
            break;
        }
        sum++;
        for(t=end;t!=sta;t=pre[t])
        {
            pre_x=pre[t];
            a[pre_x][t]=0;
            a[t][pre_x]=1;
        }
    }
    return sum;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值