Clairewd’s message

Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table. 
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages. 
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you. 
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem. 
Input
The first line contains only one integer T, which is the number of test cases. 
Each test case contains two lines. The first line of each test case is the conversion table S. S i i is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete. 
Hint
Range of test data: 
T<= 100 ; 
n<= 100000; 
Output
For each test case, output one line contains the shorest possible complete text.
Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde
Sample Output
abcdabcd

qwertabcde

题目意思:题目看了好久,很难理解,看的莫名奇妙哭

题目就是让你通过一个密文转换表,将给出得一个串“密文+明文”(密文是完整的,但明文

未知)补全。

解题思路:理解了题目意思就好写了,一道kmp的题,其实密文和明文构成了一种映射的关系,在转换表

中是一一对应的,于是可以先将整个串转换成“明文”,然后与原串比较,重合的部分的长度

就是密文的长度,然后输出就行;

#include<iostream>
#include<cstring>

using namespace std;

int const maxn=100005;


char str[maxn],str1[maxn];
int next1[maxn];
int len,len1,mark,Max;

void sign(char *str1,int next1[])
{
	int i,j;
	next1[0]=-1;
	i=-1,j=0;
	int len1=strlen(str1);
	while(j<len1-1)
	{
	    if(i==-1||str1[i]==str1[j])
	    {
	    	i++;
	    	j++;
	    	next1[j]=i;
		}
		else
		{
			i=next1[i];
		}
	}	
}

int kmp(char *str,char *str1)
{
	int m=0,n=0;
	sign(str1,next1);
	int len=strlen(str);
	int len1=strlen(str1);
	if(len%2==0)
	{
		m=len/2;
	}
	else
	{
		m=len/2+1;
	}
	while((m<len)&&(n<len1))
	{
		if(n==-1||str[m]==str1[n])
		{
			m++;
			n++;
		}
		else
		{ 
			n=next1[n];
		}	
	}
	return n;
}


int main()
{
	char s,ss,strm[maxn],strm1[maxn];
	int T;
	cin>>T;
	while(T--)
	{
		scanf("%s",strm);    //转换表
		scanf("%s",str);    //密文+明文 
		for(int i=0;i<26;i++)
		{
			s=strm[i];
			strm1[s]=i;         //转换表中每一字母与26个字母一一对应 
		}
		int lenn=strlen(str);
		for(int i=0;i<lenn;i++)
		{
			ss=strm1[str[i]];   //密文的每一个字母在26个字母中的位置 
	        str1[i]='a'+ss;      //ASCII转换为明文 
		}
		
		int num=kmp(str,str1);
		if(2*num==lenn)
		{
			cout<<str<<endl;
		}
		else
		{
			cout<<str;
			for(int i=num;i<lenn-num;i++)
			{
				cout<<str1[i];
			}
			cout<<endl;
		}
	}
	return 0;	   
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值