Shortest Prefixes

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car

carbonate carbona

题目意思:输入一些单词,找出这些单词本身特有的最短前缀。

解题思路:将这些单词建树,用一个标记p->v=-1记录哪一字母是一个单词最后一个字母,然后再一次将它

们输入进去进行查找,找到一个p->=-1但之后的字母所对应的p->!=-1。于是下一个字母之前

的这些字母组成的单词就是它所特有的前缀。

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

char s[2001][21];

struct trie{
	int v;
	trie *next[26];
	trie(){
		v=0;
		for(int i=0;i<26;i++)
		{
			next[i]=NULL;
		}
	}
}; 

trie *root;

void creat(trie *root,char *str)
{
    int len=strlen(str);
	trie *p=root,*q;
	//len--;
	for(int i=0;i<len;i++)
	{
		int sign=str[i]-'a';
		if(p->next[sign]==NULL)
		{
			q=new trie();
			q->v=1;
			p->next[sign]=q;
			p=p->next[sign];
		}
		else
		{
			p->next[sign]->v++;
			p=p->next[sign];
		}
	}	
}

void find(char *str)
{
	int len=strlen(str);
	trie *p=root;
	for(int i=0;i<len;i++)
	{
		int id=str[i]-'a';
		p=p->next[id];
		if(p==NULL)
		   return;
		cout<<str[i];
		if(p->v==1)
		{
			cout<<endl;
			return;
		}
	}
	cout<<endl;
}

void del(trie *root)
{
	for(int i=0;i<26;i++)
	{
		if(root->next[i])
		{
			del(root->next[i]); 
		}
	}
	delete(root);
}

int main()
{
	int size=0;
	root=new trie();
	while(~scanf("%s",s[size]))
	{
		creat(root,s[size]);
		size++;
	}
	for(int i=0;i<size;i++)
	{
		cout<<s[i]<<" ";
		find(s[i]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值