Shortest Prefixes(字典树)

Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.
An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
题意
输入若干单词,求这些单词中每个单词的最短前缀----这个前缀就只这一个单词有。
如果没有这样的最短前缀,就输出这一整个单词。
题解
把这些单词建成一个字典树,在建树的过程中,每经过一个节点,就用一个辅助数组把这个节点加一次,vis[root],存的是从根节点开始到下标为root的节点这一路的字母即前缀,有多少个单词有这样的前缀。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <sstream>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <set>
#define INF 0x3f3f3f3f
#define fori(a,b) for(int i=a;i<b;i++)
#define forj(a,b) for(int j=a;j<b;j++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;
//const double PI = acos(-1);
const int MAX=1e5;
char s[1111][50];
int trie[MAX][30];  //trie[i][j]=k,下标为i,字母为j的节点的j的后边字母的下标 
int vis[MAX];       
int cnt=1;
void build_trie(char s[])    //建树
{
    int root = 0;
    fori(0,s[i]){
        int next = s[i]-'a';
        if(!trie[root][next])
            trie[root][next]=cnt++;
        root=trie[root][next];
        vis[root]++;
    }
}

string query(char s[])    //查询
{
    string ans;
    int root=0;
    fori(0,s[i]){
        if(vis[root]==1)
            return ans;
        int next=s[i]-'a';
        ans+=s[i];
        root=trie[root][next];
    }
    return ans;
}
int main()
{
    mem(trie,0);
    mem(vis,0);
    int n=0;
    while(scanf("%s",s[n])!=EOF){
        build_trie(s[n]);
        n++;
    }
    fori(0,n){
        cout << s[i] << " "<< query(s[i]) << endl;
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值