【JAVA】Gary's Calculator

Gary's Calculator

Problem Description
Gary has finally decided to find a calculator to avoid making simple calculational mistakes in his math exam. Unable to find a suitable calculator in the market with enough precision, Gary has designed a high-precision calculator himself. Can you help him to write the necessary program that will make his design possible?
For simplicity, you only need to consider two kinds of calculations in your program: addition and multiplication. It is guaranteed that all input numbers to the calculator are non-negative and without leading zeroes.
 
Input
There are multiple test cases in the input file. Each test case starts with one positive integer N (N < 20), followed by a line containing N strings, describing the expression which Gary's calculator should evaluate. Each of the N strings might be a string representing a non-negative integer, a "*", or a "+". No integer in the input will exceed 10 9.
Input ends with End-of-File.
 
Output
For each test case, please output one single integer (with no leading zeros), the answer to Gary's expression. If Gary's expression is invalid, output "Invalid Expression!" instead. Please use the format indicated in the sample output. 
 
SampleInput
3
100 + 600
3
20 * 4
2
+ 500
5
20 + 300 * 20
 
SampleOutput
Case 1: 700
Case 2: 80
Case 3: Invalid Expression!
Case 4: 6020



import java.io.*;
import java.util.*;
import java.math.*;
public class Main
{
    public static void main(String[] args)
    {
	int n,ti=1;
        char[][] ch=new char[25][];
        BigInteger[] q=new BigInteger[25];
        Scanner cin = new Scanner(new BufferedInputStream(System.in));
	BigInteger summ=BigInteger.valueOf(0),temp,ten=BigInteger.valueOf(10);
	for(boolean flag=false,tmt=false;cin.hasNext();flag=false,tmt=false)
	{
                int top=0;
                n=cin.nextInt();
		summ=BigInteger.valueOf(0);
		for(int i=0;i<n;++i)
		{
                        ch[i]=cin.next().toCharArray();
			if(flag)
			{
				if(ch[i][0]!='*'&&ch[i][0]!='+')
					tmt=true;
				flag=false;
			}
			else
			{
				if(ch[i][0]=='*'||ch[0][0]=='+')
					tmt=true;
				flag=true;
			}
		}
		System.out.printf("Case %d: ",ti++);
		if(tmt||(!flag))
		{
			System.out.printf("Invalid Expression!\n");
			continue;
		}
		for(int i=0;i<n;++i)
		{
			temp=BigInteger.valueOf(0);
			if(ch[i][0]!='*'&&ch[i][0]!='+')
			{
                                temp=new BigInteger(String.valueOf(ch[i]));
				//for(int j=0;j<strlen(ch[i]);++j)
				//	temp=temp.multiply(ten).add(BigInteger.valueOf(ch[i][j]-'0'));
				if(i-1>0&&(ch[i-1][0]=='*'))
					temp=temp.multiply(q[--top]);
				q[top++]=temp;
			}
		}
		for(--top;top>=0;--top)
			summ=summ.add(q[top]);
		System.out.println(summ.toString());
	}
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值