【AC自动机】 hdu2896 病毒侵袭

病毒侵袭

http://acm.hdu.edu.cn/showproblem.php?pid=2896


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

Sample Input
  
  
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
  
  
web 1: 1 2 3 total: 1

照着模板敲就能过的题目。


#include<cstdio>
#include<cstring>
#include<set>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
    node *next[130],*fail;
    int id;
    node()
    {
        memset(next,0,sizeof(next));
        fail=NULL;
        id=0;
    }
}*head;
char s[10005],t[205];
set<int,less<int> > out;
void build(char *x,node *head,int id)
{
    int len=strlen(x);
    for(int i=0; i<len; ++i)
    {
        int k=x[i];
        if(head->next[k]==NULL)
            head->next[k]=new node();
        head=head->next[k];
    }
    head->id=id;
}
void build_fail(node *head)
{
    node *now,*p;
    queue<node*> q;
    head->fail=NULL;
    q.push(head);
    for(; !q.empty();)
    {
        now=q.front();
        q.pop();
        for(int i=0; i<130; ++i)
            if(now->next[i])
            {
                p=now->fail;
                for(; p&&!p->next[i];) p=p->fail;
                now->next[i]->fail=p?p->next[i]:head;
                q.push(now->next[i]);
            }
    }
}
void ac_find(node *head,char *s)
{
    int len=strlen(s);
    out.clear();
    node *p=head;
    for(int i=0;i<len;++i)
    {
        int k=s[i];
        for(;p->next[k]==NULL&&p!=head;p=p->fail);
        p=p->next[k]==NULL?head:p->next[k];
        node *tmp=p;
        for(;tmp!=head;)
        {
            if(tmp->id)
               out.insert(tmp->id);
            tmp=tmp->fail;
        }
    }
}
int main()
{
    int n,m;
    for(; ~scanf("%d",&n);)
    {
        head=new node();
        for(int i=1; i<=n; ++i)
        {
            scanf("%s",t);
            build(t,head,i);
        }
        build_fail(head);
        int summ=0;
        scanf("%d",&m);
        for(int i=1; i<=m; ++i)
        {
            scanf("%s",s);
            ac_find(head,s);
            if(out.size()!=0)
            {
                printf("web %d:",i);
                for(set<int>::iterator it=out.begin();it!=out.end();++it)
                    printf(" %d",*it);
                printf("\n");
                summ++;
            }
        }
        printf("total: %d\n",summ);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值