uva 725 - Division

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits
0
through
9
once each, such that the first number divided by the second is equal to an integer
N
, where
2

N

79
. That is,
abcde

f ghij

N
where each letter represents a different digit. The first digit of one of the numerals is allowed to be
zero.
Input
Each line of the input file consists of a valid integer
N
. An input of zero is to terminate the program.
Output
Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and,
of course, denominator).
Your output should be in the following general form:
xxxxx
/

xxxxx

N
xxxxx
/

xxxxx

N
.
.
In case there are no pairs of numerals satisfying the condition, you must write ‘
There are no
solutions for
N
.
’. Separate the output for two different values of
N
by a blank line.
Sample Input
61
62
0
Sample Output
There are no solutions for 61.
79546 / 01283 = 62
94736 / 01528 =62
分析:水题,暴力求解分子,在判断分母。其实倒是有next_permutation()可以用。还是自己写下吧!
直接求10个数会超时的!

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<cstdio>
using namespace std;

typedef struct tagcharitem
{
    char c;
    int value;
}charitem;
int n,co=0;
bool flag;
charitem a[]={
              {'f',-1},
              {'g',-1},{'h',-1},{'i',-1},{'j',-1}
              };

int mark[10];
map<int,int> m;

bool judge(int k1,int k2)//判断位数是否重复
{
    m.clear();
    if(k1<10234)
        m[0]++;
        if(k2<10234)
            m[0]++;
    while(k1)
    {
        int t=k1%10;
        if(m[t]>0)
            return false;
        m[t]++;
        k1/=10;
    }
    while(k2)
    {
        int t=k2%10;
        if(m[t]>0)
            return false;
         m[t]++;
        k2/=10;
    }
    if(m[0]>1)
    return false;
    return true;
}

void search(int cnt)   //暴力组合分子
{
    if(cnt==5)
    {
      int  sum1=a[0].value*10000+a[1].value*1000+a[2].value*100+a[3].value*10+a[4].value;
      int  sum2=sum1*n;
      if(judge(sum2,sum1)&&sum2<=98765)
      {
       printf("%05d / %05d = %d\n",sum2,sum1,n);
       flag=true;
      }
      return;
    }

    else for(int i=0;i<=9;i++)
    {
        if(mark[i])
        continue;
        a[cnt].value=i;
        mark[i]=1;
        search(cnt+1);
        a[cnt].value=-1;
        mark[i]=0;
    }
}

int main()
{
    while(scanf("%d",&n))
    {
        if(n==0) break;
       co++;
       if(co!=1)
        printf("\n");
    flag=false;
    memset(mark,0,sizeof(mark));
    search(0);
    if(flag==false)
        printf("There are no solutions for %d.\n",n);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值