Given three integers A, B and C in [−2
63
,2
63
], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases
follow, each consists of a single line containing three integers A, B and C, separated by
single spaces.
Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise,
where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
判断a+b是否大于c。这里需要注意的是a+b可能溢出,如果a大于0且b大于0,但相加得到的却是小于等于0的说明
是正溢出,这时肯定比c大(因为c肯定在long long的范围内)。如果a小于0且b小于0,但相加得到的却是大于
等于0的说明是负溢出,这是肯定比c小。其他情况就和平常计算一样。这里还要注意a+b要赋值给一个变量再和c
比较。
---------------------
原文:https://blog.csdn.net/kakitgogogo/article/details/51954542
AC代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int T;
int t = 0;
long long a,b,c;
scanf("%d",&T);
while(T--)
{
scanf("%lld%lld%lld",&a,&b,&c);
printf("Case #%d: ",++t);
long long res = 0;
res = a+b;
if(a>0&&b>0&&res<=0)
printf("true\n");
else if(a<0&&b<0&&res>=0)
printf("false\n");
else if(res>c)
printf("true\n");
else printf("false\n");
}
return 0;
}