1065 A+B and C (64bit) (20分)

题目

Given three integers A, B and C in [ − 2 63 , 2 63 ] [-2^{63},2^{63}] [263,263], you are supposed to tell whether A + B > C A+B\gt C A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T ( ≤ 10 ) T(\le10) T(10). Then T test cases follow, each consists of a single line containing three integers A A A, B B B and C C C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A + B > C A+B>C A+B>C, or KaTeX parse error: Expected 'EOF', got '#' at position 6: Case #̲X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题目大意

判断 A + B A+B A+B C C C的大小。

思路

题目给的数据范围刚好是long long,所以 A + B A+B A+B可能会溢出,第一眼看到题目,以为是大整数相加的问题,还是做题太少了,有点蠢,哈哈;

其实这道题考的是溢出的问题,

  1. A + B ≥ 2 63 A+B\ge2^{63} A+B263时,显然 A + B > C A+B>C A+B>C成立,但是 A + B A+B A+B会超过long long的最大值,发生溢出,而 A A A B B B的最大值为 2 63 − 1 2^{63}-1 2631,所以 A + B A+B A+B的最大值为 2 64 − 2 2^{64}-2 2642,所以使用long long存储后后溢出的值的区间为 [ − 2 63 , − 2 ] [-2^{63},-2] [263,2]
  2. A + B < − 2 63 A+B\lt-2^{63} A+B<263时,显然 A + B < C A+B\lt C A+B<C成立,但是 A + B A+B A+B会超过long long的最大值,发生溢出,而 A A A B B B的最小值为 − 2 63 -2^{63} 263,所以 A + B A+B A+B的最小值为 − 2 64 -2^{64} 264,所以使用long long存储后溢出的值的区间为 [ 0 , 2 63 ) [0,2^{63}) [0,263);

代码

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int main(){
    int n;
    scanf("%d", &n);
    for(int t=1; t<=n; t++){
        long long a, b, c, sum;
        scanf("%lld%lld%lld", &a, &b, &c);
        printf("Case #%d: ", t);
        sum = a + b;
        if(a > 0 && b > 0 && sum < 0)
            printf("true\n");
        else if(a < 0 && b < 0 && sum >= 0)
            printf("false\n");
        else if (sum > c)
            printf("true\n");
        else
            printf("false\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值