ZOJ 1711--DFS--组合--剪枝/去重

这是一篇关于ZOJ 1711编程题目的解析,主要涉及深度优先搜索(DFS)在求解组合问题中的应用。题目要求找出所有可能的数列和,并按特定规则排序和去重。文章提供了剪枝代码以优化搜索过程。
摘要由CSDN通过智能技术生成


Sum It Up

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.


Input

The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.


Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.


Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0


Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

分析:这题就是在一组数中选出和刚好等于T的数,也就是个组合问题,不过要去掉相同的组合。可以用一个中间值剪枝也可以用一个二维数组保存所有的组合然后遍历去掉相同的。用剪枝更简单,因为本题已经规定了输入的数按非增顺序,而dfs搜索的时候从前往后搜索的,所以只要下次搜索的节点值等于上次搜索是保存的中间值,那么必定是重复的,就可以剪掉。

剪枝代码:


#include<iostream>
using namespace std;
int t,n,a[20];
int sum;
int b[20];
int mark;
int cnt;
int ok;
void dfs(int i)
{
	if(sum>t) return;
	if(sum==t){
		ok=1;
	   cout<<b[0];if(cnt==1){
	   cout<<endl;return;}for(int j=1;j<cnt;j++) cout<<"+"<<b[j];cout<<endl;return;}
	
	if(i>=n) return;
	if(a[i]!=mark){
	b[cnt++]=a[i];
	sum+=a[i];
	dfs(i+1);
	cnt--;
	sum-=b[cnt];
	mark=a[i];}
	dfs(i+1);
}
int main()
{
	while(cin>>t>>n){
		if(!n) break;
		ok=0;
		mark=0;
		for(int i=0;i<n;i++) cin>>a[i];
		cout<<"Sums of "<<t<<":"<<endl;
		sum=0;
		cnt=0;
		dfs(0);
		if(!ok) cout<<"NONE"<<endl;
	}
}



去重代码:

#include<iostream>
#include<cstring>
using namespace std;
int t,n,a[20];
int sum;
int b[20],che[5000][20];
int cnt;
int ok,num;
int len[5000];
int vis[5000],flag;
void dfs(int i)
{
	if(sum>t) return;
	if(sum==t){
		ok=1;
	    len[num]=cnt;
	    for(int j=0;j<cnt;j++){
	    	che[num][j]=b[j];
	    }
	    num++;
	    return;
	}
	if(i>=n) return;
	b[cnt++]=a[i];
	sum+=a[i];
	dfs(i+1);
	cnt--;
	sum-=b[cnt];
	dfs(i+1);
}
void cut()
{
	for(int i=0;i<num;i++)
	for(int j=i+1;j<num;j++){
		if(len[i]==len[j]&&!vis[j]){
			for(int k=0;k<len[j];k++){
				if(che[i][k]!=che[j][k]){
					flag=1;break;
				}
			}
			if(!flag) vis[j]=1;flag=0;
		} 
	}
	for(int i=0;i<num;i++)
	if(!vis[i]){
	cout<<che[i][0];
	for(int j=1;j<len[i];j++) cout<<"+"<<che[i][j];
	cout<<endl;
	}
	return;
}
int main()
{
	while(cin>>t>>n){
		if(!n) break;
		memset(vis,0,sizeof(vis));
		memset(che,0,sizeof(che));
		ok=0;
		for(int i=0;i<n;i++) cin>>a[i];
		cout<<"Sums of "<<t<<":"<<endl;
		sum=0;
		cnt=0;
		num=0;
		flag=0;
		dfs(0);
		cut();
		if(!ok) cout<<"NONE"<<endl;
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值