poj 3295 Tautology

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example,ApNp is a tautology because it is true regardless of the value of p. On the other hand,ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source

Waterloo Local Contest, 2006.9.30


/*
     学离散学疯了的同学才会有这种题....
     题意大概是这样,给予运算式,根据题目中给予的真值表处理运算式,将所有情况都考虑到,如果给予的运算式为重言式(永真式)输出 tautology,否则为not
     有2^5种情况,将每一种都考虑到,跑一个2^5的循环,从后至前读取字符,读到运算符之后再按题目中的真值表进行处理,用STL中的stack更方便一些。
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <stack>
#include <cmath>
#define INF 0x3f3f3f3f

using namespace std;

char ch[110];
int p,q,r,s,t,K,A,N,C,E,x,y,flag;
int main()
{
    while(~scanf("%s",ch) && strcmp(ch,"0"))
    {
        stack<int>l;
        flag = 0;
        for(int p=0; p<2; p++)
        {
            for(int q=0; q<2; q++)
            {
                for(int r=0; r<2; r++)
                {
                    for(int s=0; s<2; s++)
                    {
                        for(int t=0; t<2; t++)
                        {
                            for(int i = strlen(ch)-1; i>=0; i--)
                            {
                                if(ch[i] == 'p')
                                    l.push(p);
                                else if(ch[i] == 'q')
                                    l.push(q);
                                else if(ch[i] == 'r')
                                    l.push(r);
                                else if(ch[i] == 's')
                                    l.push(s);
                                else if(ch[i] == 't')
                                    l.push(t);
                                else if(ch[i] == 'K')
                                {
                                    x = l.top();l.pop();
                                    y = l.top();l.pop();
                                    l.push(x&&y);
                                }
                                else if(ch[i] == 'A')
                                {
                                    x = l.top();l.pop();
                                    y = l.top();l.pop();
                                    l.push(x||y);
                                }
                                else if(ch[i] == 'N')
                                {
                                    x = l.top();l.pop();
                                    l.push(!x);
                                }
                                else if(ch[i] == 'C')
                                {
                                    x = l.top();l.pop();
                                    y = l.top();l.pop();
                                    if(x == 1 && y==0)
                                        l.push(0);
                                    else
                                        l.push(1);
                                }
                                else if(ch[i] == 'E')
                                {
                                    x = l.top();l.pop();
                                    y = l.top();l.pop();
                                    if((x==1 && y==1) || (x==0 && y==0))
                                        l.push(1);
                                    else
                                        l.push(0);
                                }
                            }
                            if(!l.top())
                                flag = 1;
                        }
                    }
                }
            }
        }
        if(flag)
            printf("not\n");
        else
            printf("tautology\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值