HDU 1016-Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53521    Accepted Submission(s): 23677


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
素数环问题,这里用的是深搜
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int n,num[21],vis[21],ring[21],mark;
int prime(int t)//判断t是否是素数
{
	if(t==1) return 0;
	if(t==2) return 1;
	for(int i=2;i<t;i++)
	{
		if(t%i==0)
		{
			return 0;
			break;
		}
	}
	return 1;
}
void print()//用来输出素数环序列的
{
	for(int i=1;i<=n;i++)
	{
		i==n ? cout<<ring[i]:cout<<ring[i]<<' ';
	}
	cout<<endl;
}
void dfs(int t)
{
	vis[t]=1;
	ring[mark++]=t;
	if(mark==n+1&&prime(ring[n]+1)) print();//这里要注意这是一个素数环,环,环,所以尾和头还要判断
	for(int i=1;i<=n;i++)
	{
		if(!vis[i]&&prime(t+i))
		{
			dfs(i);
		}
	}
	vis[t]=0;
	mark--;
}
int main()
{
	int count=0;
	while(cin>>n)
	{
		count++;
		mark=1;
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++)//这个num完全没必要,我强迫症...
			num[i]=i;
		cout<<"Case "<<count<<':'<<endl;
		dfs(1);
		cout<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值