hdu 1010 Tempter of the Bone

额,虽然不是自己的思想,但也不是copy,写个原创没问题吧,嘿嘿Tempter of the BoneTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 40763 Accepted Submission(s): 11029Problem DescriptionThe doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. InputThe input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:'X': a block of wall, which the doggie cannot enter; 'S': the start point of the doggie; 'D': the Door; or'.': an empty block.The input is terminated with three 0's. This test case is not to be processed. OutputFor each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. Sample Input4 4 5S.X...X...XD....3 4 5S.X...X....D0 0 0 Sample OutputNOYES AuthorZHANG, Zheng SourceZJCPC2004 RecommendJGShining

 

#include<stdio.h>
#include<mem.h>
#include<iostream>
using namespace std;
char map[7][7];
bool vis[7][7];
char c[10];
bool flag;
int t,m,n;
int dogx,dogy,sx,sy;
int dxx[]={-1,0,1,0};
int dyy[]={0,1,0,-1};

int abss(int a,int b)
{
    if(a>b)return a-b;
    else return b-a;
}
void DFS(int dx,int dy,int step)
{
    if(flag==true){return;}
    if(step==t)
    {
        if(dx==sx&&dy==sy)
        {
            flag=true;
        }
        return;
    }
    int l=abss(dx,sx)+abss(dy,sy);
    if(l+step>t){return;}
    if((l+t-step)%2!=0){return;}
    for(int i=0;i<=3;i++)
    {
        int nx=dx+dxx[i];
        int ny=dy+dyy[i];
        if(nx>=1&&ny>=1&&nx<=m&&ny<=n&&vis[nx][ny]==false&&map[nx][ny]!='X')
        {
            vis[nx][ny]=true;
            DFS(nx,ny,step+1);
            vis[nx][ny]=false;
        }
    }

}
int main()
{
    int i,j;
    int numx;
    while(~scanf("%d%d%d",&m,&n,&t))
    {
        if(m==0&&n==0&&t==0)
        {
            break;
        }
        numx=0;
        memset(map,'.',sizeof(map));
        memset(vis,false,sizeof(vis));
        for(i=1;i<=m;i++)
        {
            scanf("%s",c);
            for(j=1;j<=n;j++)
            {
                map[i][j]=c[j-1];
                if(map[i][j]=='X')
                {
                    numx++;
                }
                else if(map[i][j]=='S')
                {
                    dogx=i;dogy=j;
                }
                else if(map[i][j]=='D')
                {
                    sx=i;sy=j;
                }
            }

        }
        if(m*n-numx-1<t)
        {
            printf("NO\n");
            continue;
        }
        flag=false;
        vis[dogx][dogy]=true;
        DFS(dogx,dogy,0);
        if(flag==true)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值