hdu 2586 How far away ?<vector>

How far away ?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2113 Accepted Submission(s): 776


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1

Sample Output
  
  
10 25 100 100

Source

Recommend
lcy
 

#include<stdio.h>
 #include<mem.h>
 #include<vector>
 using namespace std;
 struct node
 {
     int oth,dis;
 }temp;
 const int maxt=40004;
 vector<node> tu[40004];
 vector<node> qu[40004];
 bool flag[maxt];
 int f[maxt];
 int path[maxt];
 int ans[maxt];
 int find(int x)
 {
     while(x!=f[x])
     {
         x=f[x];
     }
     return x;
 }
 int LCA(int k)
 {
     int i,j;
     int oth1,oth2;
     for(i=0;i<tu[k].size();i++)
     {
         oth1=tu[k][i].oth;
         if(flag[oth1]==false)
         {
             flag[oth1]=true;
             path[oth1]=path[k]+tu[k][i].dis;
             LCA(oth1);
             f[oth1]=k;
             for(j=0;j<qu[oth1].size();j++)
             {
                 oth2=qu[oth1][j].oth;
                 if(flag[oth2]==true&&ans[qu[oth1][j].dis]==0)
                 {
                     if(oth1!=oth2)
                     {
                         ans[qu[oth1][j].dis]=path[oth1]+path[oth2]-2*path[find(oth2)];
                     }
                 }
             }
         }
     }
     return 0;
 }
 int main()
 {
     int t,i,m,n;
     int a,b,c;
     scanf("%d",&t);
     while(t>=1)
     {
         scanf("%d%d",&n,&m);
         for(i=1;i<=n;i++)
         {
             f[i]=i;
             flag[i]=false;
             path[i]=0;
             ans[i]=0;
             tu[i].clear();
             qu[i].clear();
         }
         for(i=1;i<n;i++)
         {
             scanf("%d%d%d",&a,&b,&c);
             temp.oth=a;
             temp.dis=c;
             tu[b].push_back(temp);
             temp.oth=b;
             tu[a].push_back(temp);
         }
         for(i=1;i<=m;i++)
         {
             scanf("%d%d",&a,&b);
             temp.oth=a;
             temp.dis=i;
             qu[b].push_back(temp);
             temp.oth=b;
             qu[a].push_back(temp);
         }
         flag[1]=true;
         path[1]=0;
         LCA(1);
         for(i=1;i<=m;i++)
         {
             printf("%d\n",ans[i]);
         }
         t--;
     }
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值