[poj 3122] Pie 二分

Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14126 Accepted: 4844 Special Judge

Description
My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input
One line with a positive integer: the number of test cases. Then for each test case:

One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source
Northwestern Europe 2006

题目链接http://poj.org/problem?id=3122

题意:给出n个pie的直径,有f+1个人,如果给每人分的大小相同(形状可以不同),每个人可以分多少。要求是分出来的每一份必须出自同一个pie,也就是说当pie大小为3,2,1,只能分出两个大小为2的份,剩下两个要扔掉。

思路:double 类型的二分 ,注意double的输出为.lf;
二分姿势while(rx-lx>1e-n) lx=mid||rx=mid;

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define PI  3.1415926535897932
double a[10005];
const double e=1e-6;  
double rx,lx;
int n,m;
int main()
{
      int T;
      scanf("%d",&T);
      while(T--)
      {

        lx=0;rx=0;
        scanf("%d%d",&n,&m);
         m+=1;
         for(int i=1;i<=n;i++)
        {
            scanf("%lf",&a[i]);
            a[i]*=a[i];
            rx=max(rx,a[i]);
        }

         double mid;
          while(rx-lx>e)
        {
            mid=(rx+lx)/2;
            int cnt=0;
           for(int i=1;i<=n;i++)
           {
             cnt+=(int)(a[i]/mid);
           }
           if(cnt<m) rx=mid;
           else lx=mid;
       }
       printf("%.4f\n",mid*PI);



      }

}
  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值