[hdu 5532] [2015ACM/ICPC亚洲区长春站 ] Almost Sorted Array 最长不下降子序列

Almost Sorted Array
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1917 Accepted Submission(s): 494

Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an, is it almost sorted?

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,…,an.

1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000.

Output
For each test case, please output “YES” if it is almost sorted. Otherwise, output “NO” (both without quotes).

Sample Input

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

Sample Output

YES
YES
NO

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=5532

题意;问给定序列去掉一个数后是否构成不下降|不上升的序列

思路;正向|反向作最长不下降子序列(nlogn的做法);
如果len==n||len==n-1输出“Yes”;

代码

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[100005];
int ans[100005];
int b[100005];
int inf=99999999;
int n;
int main()
{
    int T;

    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[n-i+1]=a[i];
            ans[i]=inf;
        }
        int len=0;

        for(int i=1;i<=n;i++)
        {
            int pos=upper_bound(ans+1,ans+1+n,a[i])-ans;
            ans[pos]=a[i];
        }

        int pos=lower_bound(ans+1,ans+1+n,inf)-ans;

        if(pos==n||pos==n+1)
        {
            printf("YES\n");
            continue;
        }
        for(int i=1;i<=n;i++) ans[i]=inf;
        for(int i=1;i<=n;i++)
        {
            pos=upper_bound(ans+1,ans+1+n,b[i])-ans;
            ans[pos]=b[i];
        }
        pos=lower_bound(ans+1,ans+1+n,inf)-ans;
        if(pos==n||pos==n+1)
        {
            printf("YES\n");
            continue;
        }
        printf("NO\n");

    }   

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值