PAT(甲级)1005.Spell It Right(20)

PAT 1002.A+B for Polynomials (25)
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

输入格式:
Each input file contains one test case. Each case occupies one line which contains an N (≤10^100​​).

输出格式:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

输入样例:

12345

输出样例:

one five

题目分析:首先注意题目的数据范围我用红色高亮了,N (≤10^100​​),而在C++中最大的整数是unsigned long long int是 2^64-1(18446744073709551615‬)显然是表示不了这么大(10^100)的数字的,对于大整数此时应该选择字符串或字符数组表示。
对于C/C++中基本数据的最大最小值,大家可以使用#include<climits>这个函数库。
在这里插入图片描述
AC代码:

#include <iostream>
#include <map>
using namesapce std;

map<int, string> mp = {{0,"zero"},{1,"one"},{2,"two"},{3,"three"},{4,"four"},{5,"five"},{6,"six"},{7,"seven"},{8,"eight"},{9,"nine"}};

int main(){
	string s;
	cin >> s;
	int sum = 0;
	for(int i=0; i<s.length(); ++i){
		sum += s[i]-'0';
	}
	s = to_string(sum);
	for(int i=0; i<s.length(); ++i){
		printf("%s",mp[s[i]-'0'].c_str());
        if(i!=s.length()-1)
            printf(" ");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值