POJ 2965 The Pilots Brothers' refrigerator 搜索+枚举

这是一个关于游戏《飞行员兄弟》中的谜题,玩家需要打开一个冰箱,冰箱有16个把手,状态为开或关。冰箱全开需要所有把手都打开。每次操作可以改变一行或一列的所有把手状态。输入给出初始把手状态,任务是找出打开冰箱所需的最小操作次数及顺序。示例展示了如何求解这个问题。
摘要由CSDN通过智能技术生成

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location[i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in rowi and all handles in columnj.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4


题意:类似 1753  每次可以翻棋但同行同列都要翻 求最小步数 并输出翻棋达到全部是"—"的顺(不一定)序;

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int step1[18][3];
int step2[18][3];
bool map2[5][5];
char map1[5][5];
int s;
int min1;
bool judge()
{
    int i,j;
    for(i=0; i<4; i++)
        for(j=0; j<4; j++)
            if(map2[i][j]==false)
                return false;
    return true;
}
void dfs(int x,int y)
{
    int i;
  for(i=0;i<4;i++)
    map2[i][y]=!map2[i][y]; 
  for(i=0;i<4;i++)
    map2[x][i]=!map2[x][i];
    map2[x][y]=!map2[x][y];
}
void work(int k,int step)
{
    int i;
    if(k==16)
    {
        if(judge()&&step<min1)
      {
          min1=step;
            for(i=0;i<min1;i++)
                step2[i][0]=step1[i][0],step2[i][1]=step1[i][1];       //关键 保存步数
      }
    }
    else
    {
        int x=k/4;
        int y=k%4;
        work(k+1,step);
        dfs(x,y);
        step1[step][0]=x;
        step1[step][1]=y;
        work(k+1,step+1);
        dfs(x,y);
    }
}
int main()
{
    int i,j;
    for(i=0; i<4; i++)
        for(j=0; j<4; j++)
        {
            cin>>map1[i][j];
            if(map1[i][j]=='+')
                map2[i][j]=false;
            else
                map2[i][j]=true;
        }
    min1=17;
    work(0,0);
    cout<<min1<<endl;
    for(i=0;i<min1;i++)
        cout<<step2[i][0]+1<<' '<<step2[i][1]+1<<endl;


    return 0;
}
 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值