HDU 1010 Tempter of the Bone 深搜剪枝

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES 题意:S为起点 D为终点 X为围墙 .为平地 一个人从s点出发 没走一步 之前走过的路会消失 问他能否在第T秒走到终点
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
char map[19][19];
int vis[19][19];
int fx[4][2]= {1,0,0,1,-1,0,0,-1};
int m,n,t;
int k;
int ex,ey;
void dfs(int x,int y,int tt)
{
    if(k==1)
        return;
    if(x==ex&&y==ey&&tt==t)
    {
        cout<<"YES"<<endl;
        k=1;
        return;
    }
    if(tt>=t)                                   // 剪枝  时间超过第T秒 则已经失去机会
        return;
    if(t-tt<abs(x-ex)+abs(y-ey))                // 剪枝  计算出最短距离大于还剩余的时间 失去机会
        return;
    if((t-tt-(abs(x-ex)+abs(y-ey)))%2!=0)       // 剪枝  经过上面的第二条剪枝 可以看做提前到终点 然后又后退
        return;                                 // 又进入终点情况(要求第T秒到达) 这个做法需要偶数步 
                                                // 非偶数则不考虑
    for(int i=0; i<4; i++)
    {
        int xx=x+fx[i][0];
        int yy=y+fx[i][1];
        if(xx<1||yy<1||xx>m||yy>n||vis[xx][yy]==1||map[xx][yy]=='X')
            continue;
        vis[xx][yy]=1;
        dfs(xx,yy,tt+1);
        if(k==1)
            return;
        vis[xx][yy]=0;
    }
}
int main()
{
    int i,j;
    int sx,sy;
    while(cin>>m>>n>>t)
    {
        if(m==0&&n==0&&t==0)
            break;
        k=0;
        memset(vis,0,sizeof(vis));   //初始化
        for(i=1; i<=m; i++)
            for(j=1; j<=n; j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(map[i][j]=='D')
                {
                    ex=i;
                    ey=j;
                }
            }
        vis[sx][sy]=1;       // 标记起点走过
        dfs(sx,sy,0);
        if(k==0)
            cout<<"NO"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值