HDU 5025 Saving Tang Monk 记忆化BFS+状态压缩

Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M).

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
  
  
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
  
  
5 impossible 8 题意: 给出一幅M X M 的地图 其中有N把钥匙(1~N表示) #代表墙壁 K代表孙悟空 T代表唐僧 S代表蛇 没走一格需要1个单位时间 杀死蛇 要加一个单位时间 求以孙 悟空为起点 按顺序取得所有钥匙 再到达唐僧位置所需的最小时间 思路: BFS 标记第N条蛇的位置 然后 用二进制数表示第I条蛇是否死亡 再用VIS记忆化 防止重复 。 代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define mm 105
#define maxx  0x3f3f3f3f
using namespace std;
char mapp[mm][mm];
int vis[mm][mm][12];  //记忆化   到达  x y 位置并取得K把钥匙所需的最小时间
int marks[mm][mm];      //标记蛇的位置
int fx[4][2]={1,0,0,1,-1,0,0,-1};
struct node{
   int x,y,step,key,snake;      //分别表示位置 时间 拿到第几个钥匙   图中蛇的状态
   friend bool operator<(const node a,node b)
   {
       return a.step>b.step;
   }
};
int ss,sx,sy,tt,m,n;
void bfs()
{
    memset(vis,maxx,sizeof(vis));   //赋为最大值
    priority_queue<node>q;
    node now,next;
    q.push((node){sx,sy,0,0,0});
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.key==n&&mapp[now.x][now.y]=='T')
        {
            ss=now.step;
            return;
        }
        int tx,ty;
        for(int i=0;i<4;i++)
        {
            tx=now.x+fx[i][0];
            ty=now.y+fx[i][1];
            if(tx<1||ty<1||tx>m||ty>m||mapp[tx][ty]=='#')
                continue;
            next.x=tx,next.y=ty;
            next.snake=now.snake;
            next.key=now.key;
            next.step=now.step+1;
            if(mapp[tx][ty]=='1'+now.key)  //碰到钥匙
            {
                next.key++;
            }
            if(mapp[tx][ty]=='S')        
            {
                int z=1<<marks[tx][ty];   //第x条蛇
                if((now.snake&z)==0)
                {
                    next.snake=now.snake|z ;  //这条蛇 没死  则标记死亡 时间+1
                    next.step++;
                }
            }
            if(next.step<vis[tx][ty][next.key])     //最小时间
            {
                vis[tx][ty][next.key]=next.step;
                q.push(next);
            }
        }
    }
    return;
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&m,&n))
    {
        ss=0;tt=0;
        if(m==0&&n==0)
            break;
        for(i=1;i<=m;i++)
            for(j=1;j<=m;j++)
        {
            cin>>mapp[i][j];
            if(mapp[i][j]=='S')
            {
                marks[i][j]=++tt;  //标记每条蛇的位置
            }
            if(mapp[i][j]=='K')
                sx=i,sy=j;
        }
        bfs();
         if(ss==0)
            cout<<"impossible"<<endl;
        else
            cout<<ss<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值