Bone Collector

 

N - Bone Collector

 
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input
The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2  31).
Sample Input
    
    
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

题意:有n种骨头,但只骨收集器体积为V;

          下面有两行,第一行是每种骨头的价值;

           第二行是对应骨头的体积;

           问:集骨收集器可以获得的总值的最大值?

#include<stdio.h>
#include<string.h>
#define MAXN 1000+1
long long int dp[MAXN][MAXN];
int W[MAXN],V[MAXN];
int n,m;
int max(int a,int b)
{
    return a>b?a:b;
}
int solve()
{
    int i,j;
    for(i=n-1; i>=0; i--)
        for(j=0; j<=m; j++)
            if(j<W[i])
                dp[i][j]=dp[i+1][j];
            else dp[i][j]=max(dp[i+1][j],dp[i+1][j-W[i]]+V[i]);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
            scanf("%d",&V[i]);
        for(int i=0; i<n; i++)
            scanf("%d",&W[i]);
        solve();
        printf("%d\n",dp[0][m]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值