Saruman's Army POJ - 3069

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case withR = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4
Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:直线上有N个点,点的位置是Xi,从这N个点中选择若干个,给他们加上标记。对每一个点,其距离为R以内的区域里必须带有标记的点(自己本身带有标记点,可以认为与其距离为0的地方有带一个有标记的点)。在满足这个条件的情况下,希望能为尽可能少的点添加标记。请问至少要有多少点被加上标记?

思路:这是一个典型的贪心题,主要的思路:从最左边开始寻找每一个被标记的点可以覆盖的范围,开始时假设当前点为被标记点,寻找可以向右覆盖的范围,进而找到真正被标记点的位置,而之前求得范围为这个被标记点的左侧范围,在用一个while循环寻找右侧的范围,在最外边加一个while循环,寻遍每一个点。

数据:10,6

1 7 15 20 30 50

开始进入循环s=1,再一个循环到15;即p(真正被标记的点为(a[i-1]=7),在一个循环到20,

也即下一个循环s=20,以此类推。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int R,n;
    int a[1010];
    while(~scanf("%d %d",&R,&n)&&(R!=-1||n!=-1))
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int cont=0;
        int i=0;
        while(i<n)
        {
           int s=a[i++];
           while(i<n&&a[i]<=s+R)
            i++;
           int p=a[i-1];
           while(i<n&&a[i]<=p+R)
            i++;
           cont++;
        }
        printf("%d\n",cont);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值