N - Trailing Zeroes (III)

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


题意:给你一个数Q,范围(1~10^8),则n!的阶乘的末尾有Q个0,求最小的n。

这个题有一个规律,n的阶乘末尾0的个数为从(1~n)n个数中5的因子个数和,也即while(n)

{

ans+=n/5;

n=n/5

}

中ans的值,知道这一规律,我们就该想到普通的for循环一定会超时,而上面的规律

正好可以使用二分查找,很方便。


#include <stdio.h>
#include <string.h>
typedef long long ll;
ll F(ll n)
{
    int ans=0;
    while(n)
    {
        ans+=n/5;
        n/=5;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=1; i<=t; i++)
    {
        ll L=10000000000,R=0,mid,term,n,k;
        scanf("%lld",&n);
        while(R<=L)
        {
            mid=(L+R)/2;
            term=F(mid);
            if(term>n)
                L=mid-1;
            else if(term<n)
                R=mid+1;
            else if(term==n)
                break;

        }
        if(term==n)
            printf("Case %d: %lld\n",i,mid-mid%5);
        else printf("Case %d: impossible\n",i);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值