最大长方形(二)nsoj 258 51 nod 1102 面积最大的矩形

题目链接

最大长方形(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
样例输入
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
样例输出
8
4000
来源
Ulm Local 2003
上传者
张云聪

  •                  
  •                  
  •                 

  • 解题思路:网上博客有几篇这个题的解答,但是我没有看那个二分查找的,而是用单调栈的思想解答的,不过我认为这个思想和双层思想一样,只不过要节省时间的多,因为把双层循环中的重复部分去掉了,双层循环从前向后,而栈是从后向前,同步更新最大的面积值,然后把那些中间数据覆盖掉。

    第一组数据中的第二个1 不好理解,当前为1 时,进入while循环,到5 时,k的值为0,加上len【t】的值为1,即为5,到4时,k+len[t]的值为2,即结果为8,到1时和为4,此后更新值一直为8。

    为什么到1 的时候和为4?因为上一个1时的 累加的(代码上面写的有)。


    #include <stdio.h>
    #include <string.h>
    #include <stack>
    using namespace std;
    
    #define max(a,b)((a)>(b)?(a):(b))
    
    long long int stack1[100000+10];
    long long int len[100000+10];
    
    int main()
    {
    	int n;
    	while(~scanf("%d",&n),n)
    	{
    		int t=0;
    		stack1[t]=-2;       //这个值与下面的那个-1,相照应,必须要小于下面的那个数,否则程序错误 
    		long long int max1=0,h;
    		memset(len,0,sizeof(len));
    		for(int i=0;i<=n;i++)
    		{  
    		 if(i<n)
    		 scanf("%lld",&h);
    		 else h=-1;
    		 if(h>stack1[t])
    		 {
    		 	stack1[++t]=h;
    		 	len[t]=1;
    		 }
    		 else
    		 {
    		 	long long int  cont=0,k=0;
    		 	while(h <= stack1[t])
    		 	{
    		 		max1=max(max1,(k+len[t])*stack1[t]); //同步更新,寻找最大的面积。 
    		 		k+=len[t--];                         //t的减少,表示覆盖了那些双层循环中重复的部分 
    			}                                        //k的增加,表示了当前stack1[t] 前面有k个大于等于它的数 
    			stack1[++t]=h;                           //len[t]值更新加上k,表示当前值h的前面有k个大于等于它的数 
    		 	len[t]=k+1;                              //且这一步就是去掉重复部分的关键 
    		 }                                          
    	   }
    	   printf("%lld\n",max1);
    	}
    	return 0;
    } 

    题目链接

    想法:这个题是我暑假做的,当时勉强看懂别人的代码,今天我在51nod上又碰到这个题,不过51nod上的题,时间要求上较为严格,上面的方法并不能通过这个题。我用到单调栈的方法去解决这个题的,大家可以看一下,单调栈和上面的方法相类似,大家可以看一下。

    #include <stdio.h>
    #include <string.h>
    #include <stack>
    #include <algorithm>
    using namespace std;
    typedef long long ll;
    struct node
    {
    	ll data;
    	ll num;
    };
    int main()
    {
       ll n;
      while(~scanf("%lld",&n)&&n)
      {
      	node p,q;
      	stack<node>Q;
      	ll max=0,m;
      	 for(int i=0;i<n;i++)
      	 {
      	 	scanf("%lld",&m);
      	 	if(i==0)
      	 	{
      	 		p.num=1;
      	 		p.data=m;
      	 		max=m;
      	 		Q.push(p);
    		}
    		else
    		{
    		   q=Q.top();
    		  if(m>=q.data)
    		  {
    		  	 p.data=m;
    		  	 p.num=1;
    		  	 Q.push(p);
    		  }	
    		  else 
    		  {
    		   	int cont=0;
    		  	 while(m<q.data)
    		  	 {	
    			    cont+=q.num;
    			    Q.pop();
    			    if(q.data*cont>max)
    			    max=q.data*cont;
    		        if(Q.size())
    		  	 	 q=Q.top();
    		  	    else break;
    			 }
    			 p.num=cont+1;
    			 p.data=m;
    			 Q.push(p);
    		  }
    		}	
    	 }
    	 ll sum=0;
    	 while(Q.size())
    	 {
    	 	p=Q.top();
    	 	Q.pop();
    	 	sum+=p.num;
    	 	if(sum*p.data>max)
    	 	max=sum*p.data;
    	 }
    	 printf("%lld\n",max);
      }
      return 0;	
    }


    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值