HDOJ 1312 Red and Black【dfs】

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14373    Accepted Submission(s): 8909


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

开始学习新知识啦~

这个是参照学长的题解才打出来的,不过,以后总会越来越好的~


#include<stdio.h>
#include<string.h>
int W,H,step;
int sx[4]={0,0,1,-1};
int sy[4]={1,-1,0,0};
char map[25][25];
void dfs(int x,int y)
{
	int k;
	if(x<0||x>=H||y<0||y>=W)return;
    if(map[x][y]=='#')return;
    step++;
    map[x][y]='#';
    for(k=0;k<4;k++)
    	 dfs(x+sx[k],y+sy[k]);
}
int main()
{
	int i,j,x,y;
	while(scanf("%d%d",&W,&H)&&(W!=0||H!=0))
	{
		getchar();
		for(i=0;i<H;i++)
		{
			for(j=0;j<W;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					x=i;y=j;
				}
			}
			getchar();
		}
		step=0;
		dfs(x,y);
		printf("%d\n",step);	
	}
	return 0;
}



2016.7.28

好丢人啊,今天重新学搜索才发现这道题我贴了两次而且描述还差不多(OTZZZZ

沉淀了很长一段时间……中间也做过几道题不过没怎么贴(多数因为不理解)现在终于把搜索理解的比较清楚了!!!!(撒花花




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值