HDOJ 2141 Can you find it?

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23726    Accepted Submission(s): 6002


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 

Recommend
威士忌
 



这题我一开始没看懂,以为Ai是A*i结果居然是A[i]…………

要注意不能直接把三个相加,这样内存会爆掉。应该先把前两个加起来然后在二分的时候把第三个数减去。

二分分的是后面输入的数,和前面相加过的数对比。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[500*500+10],L[511],M[511],N[511];
int main()
{
	int l,n,m,ans,i,j,k,C,S;
	int count=1;
	while(~scanf("%d%d%d",&l,&n,&m))
	{
		printf("Case %d:\n",count++);
		for(i=1;i<=l;i++)
			scanf("%d",&L[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&N[i]);
		for(i=1;i<=m;i++)	
			scanf("%d",&M[i]);
		ans=0;
		for(i=1;i<=l;i++)
			for(j=1;j<=n;j++)
				a[ans++]=L[i]+N[j];
		sort(a,a+ans);
		scanf("%d",&C);
		while(C--)
		{
			int flag=0;
			scanf("%d",&S);
			int l,r;
			int mid;
			for(i=1;i<=m;i++)
			{
				if(flag)
					break;
				l=0;r=ans;
				while(l<r)
				{
					mid=(l+r)/2;
					if(a[mid]==S-M[i])
					{
						flag=1;
						break;
					}
					if(a[mid]>S-M[i])	r=mid;
					else	l=mid+1;
				}
			}
			if(flag)
				printf("YES\n");
			else
				printf("NO\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值