hdoj2141 Can you find it?

题目:

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

这道题是给你3个数字,分别是3个数组元素的个数,然后是3个数组。之后给你一个数字,代表要测试多少组,每一组一个数字,如果能分别从三个数组中各选出一个,使这三个数字之和等于该数字,则为YES,否则为NO.

如果直接三重循环,肯定超时,因此此题需要对方法进行优化。

此题可以先用二重循环将前面两个数组的和的所有情况列出,单独存入一个数组。之后遍历另一个数组,将测试数字与另一个数组里面的数字相减,看结果能否在那个由前两个数组元素之和的数组内找到。

找数字可以用二分的方法进行优化。

参考代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
const int N = 500+10;
using namespace std;
int l,m,n;
int k;
int a[N],b[N],c[N];
int sum[N*N];
void init() {
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(c,0,sizeof(c));
    memset(sum,0,sizeof(sum));
}
void input() {
    for (int i = 0;i < l;++i) {
        scanf("%d", &a[i]);
    }
    for (int i = 0;i < m;++i) {
        scanf("%d", &b[i]);
    }
    for (int i = 0;i < n;++i) {
        scanf("%d", &c[i]);
    }
}
void combin() {
    k = 0;
    for (int i = 0;i < l;++i) {
        for (int j = 0;j < m;++j) {
            sum[k++] = a[i] + b[j]; 
        }
    }
    sort(sum,sum+k);
}
void twopoint(int num) {
    bool flag = false;
    for (int i = 0;i < n;++i) {
        int key = num - c[i];
        int left = 0,right = k - 1;
        while (left <= right) {
            int mid = left + (right - left) / 2;
            if (sum[mid] == key) {
                flag = true;
                break;
            }
            else if (key < sum[mid]) {
                right = mid - 1;
            }
            else {
                left = mid + 1;
            }
        }
    }
    if (flag) printf("YES\n");
    else printf("NO\n");    
} 
int main() {
    int cnt = 1;
    while (scanf("%d%d%d", &l, &m, &n) != EOF) {
        init();
        input();
        int s;
        int num;
        scanf("%d", &s);
        combin();
        printf("Case %d:\n", cnt);        
        for (int i = 1;i <= s;++i) {
            scanf("%d", &num);
            twopoint(num);    
        }
        cnt++;
    }
    return 0;
}


另外,此题也有需要注意的地方:先求和(类似打表),不然也有可能超时。
此题的输入输出也需要注意。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值