HDU 1241 Oil Deposits【dfs&bfs】

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24462    Accepted Submission(s): 14056


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
 


贴这题吧,最主要的原因是翻译问题= =

这一题的相邻居然有斜对角,这样的话,就是只要一圈有联系的就都是相邻的,是一块油田。注意这一点就好了,剩下的都很水。下面写一下题意省的我下回又看半天题……


题意:有一个公司发现了一片产油地。现在这块地被分成很多小块,有的小块里有油,有的没。相邻的有油的小块被看做同一块油田。问:这块产油地里有多少块油田。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[111][111];
int ans,n,m;
void dfs(int x,int y)
{
	if(x<0||x>=m||y<0||y>=n)return;
	if(map[x][y]!='@')return;
	map[x][y]='*';	
	dfs(x,y+1);
	dfs(x,y-1);
	dfs(x+1,y);
	dfs(x+1,y+1);
	dfs(x+1,y-1);
	dfs(x-1,y);
	dfs(x-1,y+1);
	dfs(x-1,y-1);
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n),n||m)
	{
		ans=0;
		for(i=0;i<m;i++)
			scanf("%s",map[i]);
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='@')
				{
					dfs(i,j);
					ans++;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


2016.7.29

这道题,bfs和dfs都能做!突然觉得这是道学习用的好题,因为非常简单,而且明显的区分出了dfs和bfs的差别。

把bfs做法贴上,两代码对比能很明显的显示出bfs是历遍所有而dfs是回溯。


#include<stdio.h>
#include<string.h>
int n,m,num;
char map[111][111];
int dis[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,-1},{-1,1}};
void bfs(int x,int y)
{
	for(int i=0;i<8;i++)
	{
		int tx=x+dis[i][0];
		int ty=y+dis[i][1];
		if(tx>=0&&ty>=0&&tx<m&ty<n&&map[tx][ty]=='@')//dfs不符合情况直接弹出了,而bfs是继续下一个节点。
		{
			map[tx][ty]='*';
			bfs(tx,ty);
		}	
	}
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n),n||m)
	{
		num=0;
		for(i=0;i<m;i++)
			scanf("%s",map[i]);
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='@')
				{
					num++;
					map[i][j]='*';
					bfs(i,j);
				}
			}
		}
		printf("%d\n",num);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值