POJ 2631 Roads in the North【裸题】

Roads in the North
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2628 Accepted: 1298

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

Source




这是道树的直径的裸题,大意是给了各个村庄之间的距离,求离得最远的两个村庄之间的距离。

贴一下模板,方便查询吧。


#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

#define N 10000+10
struct a
{
	int t,w,next;
}edge[N*2];
int head[N],vis[N],dis[N];
int ans,Tnode,edgenum;
void addedge(int u,int v,int w)//储存该图 
{
	edge[edgenum].t=v;
	edge[edgenum].w=w;
	edge[edgenum].next=head[u];
	head[u]=edgenum++;
}

void bfs(int s)//用bfs对图进行搜索 
{
	int i,u,v;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	queue<int> q;
	q.push(s);
	vis[s]=1;dis[s]=0;ans=0;
	while(!q.empty())
	{
		u=q.front();
		q.pop();
		for(i=head[u];i!=-1;i=edge[i].next)
		{
			v=edge[i].t;
			if(!vis[v])
			{
				if(dis[v]<dis[u]+edge[i].w)
				{
					dis[v]=dis[u]+edge[i].w;
					if(ans<dis[v])
					{
						ans=dis[v];
						Tnode=v;
					}
				}
				vis[v]=1;
				q.push(v);
			}
		}
	}
}
int main()
{
	int x,y,w;
	memset(head,-1,sizeof(head));
	edgenum=0;
	while(~scanf("%d%d%d",&x,&y,&w))
	{
		addedge(x,y,w);
		addedge(y,x,w);
	}
	bfs(1);//第一次找起点 
	bfs(Tnode);//第二次从起点开始找终点 
	printf("%d\n",ans);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值