poj2631Roads in the North 树的直径

Roads in the North

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

思路:

很明显是求树直径的

代码:

#include<cstdio>
#include<algorithm>
#include<queue>
#include<iostream>
#include<cstring>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int maxn = (int)1e4 + 10;
vector<pair<int,int> > G[maxn];
int dis[maxn],ans;
bool vis[maxn];
int bfs(int x)
{
	mem(dis);
	mem(vis);
	queue<int> q;
	q.push(x);
	int p = 0;
	vis[x] = 1,dis[x] = 0;
	while (!q.empty())
	{
		int t = q.front();
		q.pop();
		if (dis[t] > ans)
		{
			ans = dis[t];
			p = t;
		}
		pair<int,int> r;
		for (int i = 0;i < G[t].size();i ++)
		{
			r = G[t][i];
			if (!vis[r.first])
			{
				vis[r.first] = 1;
				dis[r.first] = dis[t] + r.second;
				q.push(r.first);
			}
		 }
	}
	return p;
}
int main()
{
	int x,y,z;
	while (cin>>x>>y>>z)
	{
		G[x].push_back(make_pair(y,z));
		G[y].push_back(make_pair(x,z));	
	}
	int point = bfs(1);
	ans = 0;
	bfs(point);
	cout<<ans<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值