E - Two Switches

Problem Statement

Alice and Bob are controlling a robot. They each have one switch that controls the robot.
Alice started holding down her button A second after the start-up of the robot, and released her button B second after the start-up.
Bob started holding down his button C second after the start-up, and released his button D second after the start-up.
For how many seconds both Alice and Bob were holding down their buttons?

Constraints

  • 0A<B100
  • 0C<D100
  • All input values are integers.
Input

Input is given from Standard Input in the following format:

A B C D
Output

Print the length of the duration (in seconds) in which both Alice and Bob were holding down their buttons.

Sample Input 1

0 75 25 100
Sample Output 1

50

Alice started holding down her button 0 second after the start-up of the robot, and released her button 75 second after the start-up.
Bob started holding down his button 25 second after the start-up, and released his button 100 second after the start-up.
Therefore, the time when both of them were holding down their buttons, is the 50seconds from 25 seconds after the start-up to 75 seconds after the start-up.

Sample Input 2

0 33 66 99
Sample Output 2

0

Alice and Bob were not holding their buttons at the same time, so the answer is zero seconds.

思路:画出一个数轴,然后把Alice和Bob的按按钮的时间段标上去,然后求公共的那部分就可以了。

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int a, b, c, d;
int sum;
cin >> a >> b >> c >> d;
if (b < c || d < a)
sum = 0;
else
{
sum = min(b, d) - max(a, c);
}
cout << sum << endl;
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值