CSU— E: Exponial

Description

Everybody loves big numbers (if you do not, you might want to stop reading at this point). There are many ways of constructing really big numbers known to humankind, for instance:

  • Exponentiation: 422016=4242...422016 times422016=42⋅42⋅...⋅42⏟2016 times.
  • Factorials: 2016!=2016 ⋅ 2015 ⋅ ... ⋅ 2 ⋅ 1.

Illustration of exponial(3) (not to scale), Picture by C.M. de Talleyrand-Périgord via Wikimedia Commons

In this problem we look at their lesser-known love-child the exponial, which is an operation defined for all positive integers n as 
exponial(n)=n(n − 1)(n − 2)21
For example, exponial(1)=1 and exponial(5)=54321 ≈ 6.206 ⋅ 10183230 which is already pretty big. Note that exponentiation is right-associative: abc = a(bc).

Since the exponials are really big, they can be a bit unwieldy to work with. Therefore we would like you to write a program which computes exponial(n) mod m (the remainder of exponial(n) when dividing by m).

Input

There will be several test cases. For the each case, the input consists of two integers n (1 ≤ n ≤ 109) and m (1 ≤ m ≤ 109).

Output

Output a single integer, the value of exponial(n) mod m.

Sample Input

2 42
5 123456789
94 265

Sample Output

2
16317634
39



思路:这题非常的幸运,最近刚看的数论的部分有道关于幂运算的题,我记e(n)=exponial(n),由指数循环定理

AB   m o d   C = AB mod φ(C)+φ(C)   m o d   C ( B > φ ( C ) ),由于e(5)=5218>109,故只要n>4就满足指数循环定理的条件,进而有 e(n)%m=nφ(m)ne(n1)%φ(m)%m ,以此递推即可。当n<5的时候直接暴力就可以了。这题有个巨坑的点,我开始满心欢喜写出来然后过了样例以为对了,一提交就wa,再提交还是wa,最后发现是没有多组输入。所以以后不管做什么,第一件事就是给多组输入。不要偷懒。!!!!

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
typedef long long ll;
ll n,m,ans;
ll fun1(ll n)
{
ll r=n,a=n;
for(ll i=2;i*i<=a;i++)
{
if(a%i==0)
{
r=r/i*(i-1);//防止数据太大溢出
while(a%i==0)
{
a/=i;
}
}
}
if(a>1)
{
r=r/a*(a-1);
}
return r;
}
ll fun2(ll x,ll n,ll maxn)
{
ll r=1;
while(n>0)
{
if(n&1)
{
r=(r*x)%maxn;
}
x=(x*x)%maxn;
n>>=1;
}
return r;
}
ll fun3(ll n,ll m)
{
if(m==1)
{
return 0;
}
if(n==1)
{
return 1;
}
else if(n==2)
{
return 2%m;
}
else if(n==3)
{
return 9%m;
}
else if(n==4)
{
return fun2(4,9,m);
}
else
{
ll phi=fun1(m);
ll z=fun3(n-1,phi);
ans=fun2(n,phi+z,m);
}
return ans;
}
int main()
{
while(cin>>n>>m)
   cout<<fun3(n,m)<<endl;
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值