PAT 1003 Emergency

Description
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4

用dfs解决,求出最短路径
但注意题目需要输出的是

the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather

#include <iostream>
#include <limits>
using namespace std;

#define MAX 510

int city, paths;  // 城市数、道路数
int map[MAX][MAX];  // 标记city之间距离
bool visited[MAX];  // 是否已访问
int team_num[MAX];  // city中team数量
int mindis = INT_MAX;  // 最小距离
int maxteam = 0;  // 最大team数量
int diffpath = 0;  // 最短通路数量

void init() {  // 只初始化存在的city
    for (int i = 0; i < city; i++) {
        visited[i] = 0;
        for (int j = 0; j < city; j++)
            map[i][j] = INT_MAX;
    }
}

void dfs(int pos, int goal, int tol_dis, int tol_team) {
    if (pos == goal) {
        if (tol_dis < mindis) {
            diffpath = 1;
            mindis = tol_dis;
            maxteam = tol_team;
            return;
        } else if (tol_dis == mindis) {
            diffpath++;
            if (tol_team > maxteam)
                maxteam = tol_team;
            return;
        } else {
            return;
        }
    }
    for (int i = 0; i < city; i++) {
        if (visited[i] == 0 && pos != i && map[pos][i] != INT_MAX) {
            visited[i] = 1;
            dfs(i, goal, tol_dis + map[pos][i], tol_team + team_num[i]);
            visited[i] = 0;
        }
    }
}

int main() {
    int start, end;
    int c1, c2, o2odis;
    int nowdis = 0, nowteam = 0;
    cin >> city >> paths >> start >> end;
    init();
    for (int i = 0; i < city; i++)
        cin >> team_num[i];
    for (int i = 0; i < paths; i++) {
        cin >> c1 >> c2 >> o2odis;
        map[c1][c2] = o2odis;
        map[c2][c1] = o2odis;
    }
    nowteam += team_num[start];
    visited[start] = 1;
    dfs(start, end, nowdis, nowteam);
    cout << diffpath << ' ' << maxteam;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值