C - Trailing Zeroes (III) LightOJ - 1138

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


/*****

思路:对0--5*x进行二分(别问我为什莫,自己好好想想)

*****/

AC:代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll judge(ll mid,ll n){
	ll s = 0;
	while(mid>=5){
		mid /= 5;
		s += mid;  
	}
	if(s>=n) return 0;
	else return 1;
}
int main()
{
	int t,ncase = 1;
	cin>>t;
	while(t--)
	{
		ll n;
		scanf("%lld",&n);
		ll low = 0,high = 5*n,mid;
		for(int i = 0;i<300;i++){
			mid = low + (high - low)/2;
			if(judge(mid,n)) low = mid + 1;
			else high = mid;
		}
		ll a = low,s = 0;
		while(low>=5){
			low /= 5;
			s += low;
		}
		printf("Case %d: ",ncase++);
		if(s == n){
			printf("%lld\n",a);
		}
		else printf("impossible\n");
	}
	
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值