UPC 5157: Treasure Map

5157: Treasure Map

时间限制: 1 Sec   内存限制: 128 MB
提交: 113   解决: 23
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

You have found a treasure map! The map leads you to several gold mines. The mines  each produce gold each day, but the amount of gold that they produce diminishes each day. There are paths between the mines. It may take several days to go from one mine to another. You can collect all of the day’s gold from a mine when you are there, but you have to move on, you cannot stay for multiple days at the same mine. However, you can return to a mine after leaving it. 

输入

Each input will consist of a single test case. Note that your program may be run multiple times on different inputs. Each test case will begin with a line containing two integers n (2 ≤ n ≤ 1,000) and m (1 ≤ m ≤ 1,000), where n is the number of mines, and m is the number of paths.  
The next n lines will each describe a mine with two integers, g (1 ≤ g ≤ 1,000) and d (1 ≤ d ≤ 1,000), where g is the amount of gold mined on day 1, and d is the amount by which the gold haul diminishes each day. For example, if g=9 and d=4, then on day 1, the mine produces  9,  on  day  2  it  produces  5,  on  day  3  it  produces  1,  and  from  day  4  on,  it produces  0  (the  mines  cannot  produce  negative  amounts  of  gold).  The  mines  are numbered 1..n in the order that they appear in the input, and you start at mine 1 on day 1. 
The next m lines will each describe a path with three integers, a, b (1 ≤ a < b ≤ n) and t (1 ≤ t ≤ 100), where the path goes from mine a to mine b, and takes t days to traverse. The paths go in both directions, so that a path that goes from a to b can also be used to go from b to a. 

输出

Output a single integer, which is the maximum amount of gold that you can collect. 

样例输入

2 1
10 1
10 2
1 2 1

样例输出

42

提示

来源

Southeast USA ICPC 2017 


题意:给n个矿,每个矿每天减少d,给m条路,从u点到v点花费k天,每天不能呆在同一个地方。求可以得到的矿产最大值。


思路:

预处理一下每个矿到第j天的剩余,然后对每个点的边DP,记录max值就是ans。

#include <cstdio>
#include <algorithm>
#include <functional>
#include <cstring>
#include <iostream>
#include <vector>
using namespace std;
typedef long long ll;
const int maxn=1e3+10,mod=1e9+7,inf=(1ll<<60);
int n,m;
int g[maxn][maxn],d[maxn];        //g[i][j] 表示第i个矿到第j天的剩余   ,d[i]表示第i个矿每天减少量;
ll dp[maxn][maxn],ans;
vector<pair<int,int> >v[maxn];   //pair 头文件是<vector>;

int main(){
    memset(g,0,sizeof(g));
    scanf("%d%d",&n,&m);
    for (int i=1;i<=n;i++){
        scanf("%d%d",&g[i][0],&d[i]);
        dp[i][0]=inf;
    }
    ans=dp[1][0]=g[1][0];
    int u,vv,c;
    for (int i=1;i<=m;i++){
        scanf("%d%d%d",&u,&vv,&c);
        v[u].push_back(make_pair(vv,c));
        v[vv].push_back(make_pair(u,c));
    }
    for (int i=1;i<=n;i++){
        for (int j=1;j<=g[i][0];j++){
            g[i][j]=(g[i][0]-d[i]*j<0)?0:g[i][0]-d[i]*j;
        }
    }
    int sz;
    for (int j=1;j<maxn;j++){
        for (int i=1;i<=n;i++){
            sz=v[i].size();   //对这个点的边进行遍历;
            for (int k=0;k<sz;k++){
                if(j-v[i][k].second>=0){
                    if(dp[v[i][k].first][j-v[i][k].second]>0){
                        dp[i][j]=max(dp[i][j],dp[v[i][k].first][j-v[i][k].second]+g[i][j]);
                    }
                }
            }
            ans=max(ans,dp[i][j]);
        }
    }
    printf("%lld\n",ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值