2:A-B Problem

Description
Calculate A-B

Input
Two decimal integers a and b(-10^100 < a,b < 10^100) in one line, separated by one space.

Output
Output a-b in one line.

Sample Input

1 2


Sample Output

-1


package OJ;

import java.math.BigInteger;
import java.util.*;

public class P2 {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		BigInteger i1 = in.nextBigInteger();               //10^100需要使用大整型
		BigInteger i2 = in.nextBigInteger();
		BigInteger sum = i1.subtract(i2);
		System.out.println(sum);
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值