Puzzle(模拟)

A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after
the following sequence of 6 moves:

  1. The square above the empty position moves.
  2. The square to the right of the empty position moves.
  3. The square to the right of the empty position moves.
  4. The square below the empty position moves.
  5. The square below the empty position moves.
  6. The square to the left of the empty position moves.
    Write a program to display resulting frames given their initial configurations and sequences of moves.
    Input
    Input for your program consists of several puzzles. Each is described by its initial configuration and
    the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting
    configuration. Subsequent lines give the sequence of moves.
    The first line of the frame display corresponds to the top line of squares in the puzzle. The other
    lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
    exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
    square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
    The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
    moves into the empty position. A denotes that the square above the empty position moves; B denotes
    that the square below the empty position moves; L denotes that the square to the left of the empty
    position moves; R denotes that the square to the right of the empty position moves. It is possible that
    there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
    occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread
    over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
    Output
    Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If
    the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final
    configuration should be displayed.
    Format each line for a final configuration so that there is a single blank character between two
    adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
    position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left,
    one for the empty position itself, and one to separate it from the square to the right.
    Separate output from different puzzle records by one blank line.
    Note: The first record of the sample input corresponds to the puzzle illustrated above.
    Sample Input
    TRGSJ
    XDOKI
    M VLN
    WPABE
    UQHCF
    ARRBBL0
    ABCDE
    FGHIJ
    KLMNO
    PQRS
    TUVWX
    AAA
    LLLL0
    ABCDE
    FGHIJ
    KLMNO
    PQRS
    TUVWX
    AAAAABBRRRLL0
    Z
    Sample Output
    Puzzle #1:
    T R G S J
    X O K L I
    M D V B N
    W P A E
    U Q H C F
    Puzzle #2:
    A B C D
    F G H I E
    K L M N J
    P Q R S O
    T U V W X
    Puzzle #3:
    This puzzle has no final configuration.

题目很长很长,而且输入输出就巨扯淡,但是题目大意很简单,就是按着方向去移动木块,跟我们小时候玩的积木一样.直接上代码,

#include <iostream>
#include <cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a[5][7];
    char cmd[1005];
    int kase=0;
    while(gets(a[0]))//也是参考了一位大牛的方法这么写的
    {
        if(a[0][0]=='Z') break;
        for(int i=1; i<5; i++)
            gets(a[i]);
        int xx=0,yy=0;
        for(int i=0; i<5; i++)
        {
            for(int j=0; j<5; j++)
                if(a[i][j]==' ')
                {
                    xx=i,yy=j;
                    break;
                }
        }
        int k=0;
        while(cin>>cmd[k])
        {
            if(cmd[k]=='0') break;
            else k++;
        }
        cmd[k]=0;
        getchar();
        int flag=0,x=xx,y=yy;
        for(int i=0; cmd[i]; i++)
        {
            if(cmd[i]=='A')
                x=xx-1,y=yy;
            else if(cmd[i]=='B')
                x=xx+1,y=yy;
            else if(cmd[i]=='L')
                x=xx,y=yy-1;
            else if(cmd[i]=='R')
                x=xx,y=yy+1;
            if(x<0||x>4||y<0||y>4)
            {
                flag=1;
                break;
            }
            else
            {
                a[xx][yy]=a[x][y];
                a[x][y]=' ';
                xx=x,yy=y;
            }
        }
        if(kase++)
            cout<<endl;
        cout<<"Puzzle #"<<kase<<":"<<endl;
        if(flag)
            cout<<"This puzzle has no final configuration."<<endl;
        else
        {
            for(int i=0; i<5; i++)
            {
                for(int j=0; j<5; j++)
                {
                    if(j) cout<<" ";
                    cout<<a[i][j];
                }
                cout<<endl;
            }
        }
    }
    return 0;
}

努力加油a啊,(o)/~

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值