PAT (Advanced Level) Practice 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K K K N 1 N_1 N1 ​ a N 1 ​a_{N_1} aN1 N 2 N_2 N2 ​ a N 2 ​a_{N_2} aN2 N K N_K NK ​ a N K ​a_{N_K} aNK

where K is the number of nonzero terms in the polynomial, N ​ i N_​i Ni and a ​ N i a​_{N_i} aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤ N K N_K NK​​ <⋯< N ​ 2 N_​2 N2 <​ N 1 N_1 N1​​ ≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

#include <bits/stdc++.h>
using namespace std;

double A[1005], B[1005];
int main() {
    int K1, K2;
    cin >> K1;
    for (int i = 0; i < K1; i++){
        int n;
        double a;
        cin >> n >> a;
        A[n]= a;
    }
    cin >> K2;
    for (int i = 0; i < K2; i++){
        int n;
        double a;
        cin >> n >> a;
        B[n] = a;
    }
    int ans = 0;
    for (int i = 0; i <= 1000; i++){
        A[i] += B[i];
        if (A[i] != 0) ans++;
    }
    cout << ans ;
    for (int i = 1000; i >= 0; i--){
        if (A[i] != 0)printf(" %d %.1lf",i,  A[i]);
    }
    cout <<"\n";
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值