PAT (Advanced Level) Practice 1002 A+B for Polynomials

1002 A+B for Polynomials
摘要由CSDN通过智能技术生成

目录

题目标题

题目描述

输入描述

输出描述

输入样例

输出样例

思路描述

Code

提交结果


题目标题

1002 A+B for Polynomials

题目描述

This time, you are supposed to find A+B where A and B are two polynomials.


输入描述

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.


输出描述

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.


输入样例

2 1 2.4 0 3.2
2 2 1.5 1 0.5


输出样例

3 2 1.5 1 2.9 0 3.2


思路描述

多项式相加,最后输出不同的幂数以及对应的系数(系数不能为0)。

所以用double数组创造由整数幂数到double系数的一个映射。


Code

#include<iostream>
using namespace std;
const int N=1010;
double s[N];
int main()
{
    int n1,n2,count=0;
    cin>>n1;
    for(int i=0;i<n1;i++)
    {
        int n;
        double a;
        scanf("%d %lf",&n,&a);//n是幂数 a是系数
        s[n]+=a;
    }
    cin>>n2;
    for(int i=0;i<n2;i++)
    {
        int n;
        double a;
        scanf("%d %lf",&n,&a);
        s[n]+=a;
    }
    for(int i=1000;i>=0;i--)
    {
        if(s[i]!=0)
            count++;
    }
    cout<<count;
    for(int i=1000;i>=0;i--)
        if(s[i]!=0)
            printf(" %d %.1lf",i,s[i]);
    return 0;
}

提交结果


 

freetalk or label

简单的题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值