PAT (Advanced Level) 1010 Radix (25分)

PAT (Advanced Level) 1010 Radix (25分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N 1 N_1 N1and N 2 N_2 N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N 1 N_1 N1 N 2 N_2 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

#include <bits/stdc++.h>
using namespace std;
string N1, N2;
int tag, radix ,flag;
int pro(char c){return isdigit(c)?c-'0':c-'a'+10;}
long long getans(string N, long long r){
    long long stand = 0;
    for (auto ch : N)stand = stand * r + pro(ch);
    return stand;
}

int main() {
    ios::sync_with_stdio(false);
    cin.tie(NULL);
    cin >> N1 >> N2 >> tag >> radix ;
    if (tag == 2) swap(N1, N2);
    long long stand = getans(N1, radix);
    char c = *max_element(N2.begin(), N2.end());
    long long left =pro(c) + 1, right = stand + 1;
    long long ans = 1;
    while (left <= right){
        long long mid = (left + right) / 2;
        long long tmp = getans(N2, mid);
       // cout << tmp << " " << stand << endl;
        if (tmp < 0 || tmp > stand) right = mid - 1;
        else if (tmp == stand) { ans = mid;break;}
        else left = mid + 1;
    }
    long long ansN2 = getans(N2, ans);
    if (ansN2 == stand) cout << ans << endl;
    else cout << "Impossible" << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值