威尔逊定理 数论

50 篇文章 0 订阅
26 篇文章 0 订阅

威尔逊定理

n为素数时

(n - 1)! \equiv -1 (mod$ $n)

(n - 2) ! \equiv 1 (mod$ $n)

应用

\sum _{k=1}^{n} \left \lfloor \frac{(3 \cdot k + 6)! + 1}{(3 \cdot k+7)} +\left \lfloor \frac{(3 \cdot k + 6)!}{(3\cdot k + 7)} \right \rfloor \right \rfloor

YAPTCHA

 

YAPTCHA

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1858    Accepted Submission(s): 960


 

Problem Description

The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute


where [x] denotes the largest integer not greater than x.

 

 

Input

The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

 

Output

For each n given in the input output the value of Sn.

 

Sample Input

 13 1 2 3 4 5 6 7 8 9 10 100 1000 10000

Sample Output

 0 1 1 2 2 2 2 3 3 4 28 207 1609

 Source

Central European Programming Contest 2008

 

 

Recommend

lcy

 

 

题解:3k + 7 为质数时, 又威尔逊定理左式等于0,右式等于-1 整式等于1

3k+7为合数时,(3k+6)!是3k +7的倍数所以\left \lfloor \frac{(3 \cdot k + 6)!}{(3\cdot k + 7)} \right \rfloor =\frac{(3 \cdot k + 6)!}{(3\cdot k + 7)},原式等于\left \lfloor \frac{1}{3k+7} \right \rfloor = 0

所以这题就是求给定集合的素数个数

/*
 *威尔逊定理
 */
#include <bits/stdc++.h>
using namespace std;
const int maxn = 3e6 +10;
const int maxm = 1e6 + 10;
int v[maxn];
vector <int> pri;
int cnt, n;
int ans[maxn];
void prime(){
    for (int i =2 ; i < maxn; i++){
        if (!v[i]) pri.push_back(i);
        for (int j = 0; j < pri.size() && pri[j] * i < maxn; j++){
            v[i * pri[j]] = 1;
            if (i % pri[j] == 0) break;
        }
    }
}

int main()
{
    prime();
    cnt = pri.size();
    int T;cin >> T;
    for (int i = 1; i < maxm; i++){
        int k = 3 * i + 7;
        if (!v[k]) ans[i] = ans[i - 1] + 1;
        else ans[i] = ans[i -1];
    }
    while (T--){
        scanf("%d", &n);
        cout << ans[n] << endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值