2016湖南省省赛G题

                                       G - Parenthesis

 

Bobo has a balanced parenthesis sequence P=p  1 p  2…p  n of length n and q questions.
The i-th question is whether P remains balanced after p  ai and p  bi  swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1.  S is empty;
2.  or there exists  balanced parenthesis sequence A,B such that S=AB;
3.  or there exists  balanced parenthesis sequence S' such that S=(S').
Input
The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10  5,1≤q≤10  5).
The second line contains n characters p  1 p  2…p  n.
The i-th of the last q lines contains 2 integers a  i,b  i (1≤a  i,b  i≤n,a  i≠b  i).

Output
For each question, output "  Yes" if P remains balanced, or "  No" otherwise.
Sample Input
4 2
(())
1 3
2 3
2 1
()
1 2
Sample Output
No
Yes
No

题解:就是一个括号配对问题。

下面附上代码:

#include<stdio.h>
#include<algorithm>
#include<stack>
using namespace std;
char str[100005];
int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m))
    {
        scanf("%s", str+1);
        int a, b;
        for(int i = 1; i <= m; i++)
        {
            scanf("%d%d", &a, &b);
            if(a>b) swap(a,b);
            if(str[b]=='(' || str[a] == str[b])//这个地方不加前面的str[b]=='(',就会超时。
            {
                printf("Yes\n");
                continue;
            }
            swap(str[a], str[b]);
            int ans = 0;
            for(int i = 1; i <= n; i++)
            {

                if(str[i] == '(') ans++;
                else ans--;
                if(ans < 0) { printf("No\n"); break;}
            }
            if(ans == 0) printf("Yes\n");
            swap(str[a], str[b]);
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值