2016湖南省省赛G-Parenthesis(CSU1809)

12 篇文章 0 订阅

Parenthesis

            Time Limit: 5 Sec       Memory Limit: 128 Mb       Submitted: 2606       Solved: 679    

Description

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi  swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists  balanced parenthesis sequence A,B such that S=AB;
3. or there exists  balanced parenthesis sequence S' such that S=(S').

Input

The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).

Output

For each question, output " Yes" if P remains balanced, or " No" otherwise.

Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2

Sample Output

No
Yes
No

Hint

Source

湖南省第十二届大学生计算机程序设计竞赛


解题思路:'('记为1,')'记为-1,求出前缀和,两个相同字符交换必然是Yes,若两个字符不相同且后一个字符为'('也必然是Yes,而'(’和‘)’交换之后,前缀和在 (l,r-1)会减少2,检查前缀的的最小值是否大于2即可



#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <map>  
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

int mi[100009][20];
int n, q;
char ch[100009];

void init()
{
	for (int i = 1; (1 << i) <= n; i++)
		for (int j = 1; j + (1 << i) - 1 <= n; j++)
			mi[j][i] = min(mi[j][i - 1], mi[j + (1 << (i - 1))][i - 1]);
}

int query(int l, int r)
{
	int k = 0;
	while (1 << (k + 1) < r - l + 1) k++;
	return min(mi[l][k], mi[r - (1 << k) + 1][k]);
}

int main()
{
	while (~scanf("%d%d", &n, &q))
	{
		mi[0][0] = 0;
		scanf("%s", ch + 1);
		for (int i = 1; i <= n; i++)
		{
			if (ch[i] == '(') mi[i][0] = mi[i - 1][0] + 1;
			else mi[i][0] = mi[i - 1][0] - 1;
		}
		init();
		while (q--)
		{
			int l, r;
			scanf("%d%d", &l, &r);
			if (l > r) swap(l, r);
			if (ch[l] == ch[r] || ch[r] == '(') { printf("Yes\n"); continue; }
			if (query(l, r - 1) >= 2) printf("Yes\n");
			else printf("No\n");
		}
	}
	return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值