PAT 1069 The Black Hole of Numbers(模拟)

PAT1069

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

 

因为题目要求输出格式一定为4位,所以当输入的数小于4位的时候,我们要补位,在后面加0即可,因为输出的是按照各个位排序后组合的新数字,所以不影响最终结果。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#define X 4
using namespace std;
typedef long long int LL;
const int MAXN(1e4);
int a[10];
void put(int temp2,int temp1,int n) {
     printf("%04d - %04d = %04d\n",temp2,temp1,n);
}
int main() {
    int n;
    cin>>n;
    while(log10(n)<3)
        n*=10;
    while(true) {
        int len=0;
        int temp=n;
        while(n) a[len++]=n%10,n/=10;
        int temp1=0,temp2=0;
        sort(a,a+len);
        for(int i=0;i<len;i++)
            temp1=temp1*10+a[i];
        for(int i=len-1;i>=0;i--)
            temp2=temp2*10+a[i];
        n=temp2-temp1;
        put(temp2,temp1,n);
        if(n==6174||n==0) break;
        while(log10(n)<3) //每次都要补位
            n*=10;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值