PAT 1069 The Black Hole of Numbers [模拟]

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174-- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

-----------------------------------这是题目和解题的分割线-----------------------------------

首先要排序,那肯定得是数组才方便操作,其次相减得用到整型,所以需要整型和数组相互转换一下。

#include<cstdio>
#include<algorithm>

using namespace std;

int s[10000];

bool cmp(int a,int b)
{
	return a>b;
}

//整型转数组 
void intToArray(int x)
{
	for(int i=0;i<4;i++)
	{
		s[i] = x%10;	
		x = x/10;
	}
}

//数组转整型 
int arrayToInt(int s[])
{
	return s[0]*1000+s[1]*100+s[2]*10+s[3];
}

int main()
{
	int x;
	scanf("%d",&x);
	//do-while至少保证一次输出,不然会漏掉x=6174的情况 
	do
	{
		intToArray(x);
		sort(s,s+4); //转成数组排序,s2是升序 
		int s2 = arrayToInt(s);
		sort(s,s+4,cmp); //降序 
		int s1 = arrayToInt(s);
		if(s1-s2==0)
		{
			printf("%04d - %04d = 0000\n",s1,s2);
			return 0;
		}
		//记得不足补零 
		printf("%04d - %04d = %04d\n",s1,s2,s1-s2);
		x = s1-s2;	
	}while(x!=6174);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值