杭电1116(并查集+欧拉路+欧拉回路)

Play on Words(难度:1)

Time Limit: 10000/5000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word “acm” can be followed by the word “motorola”. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

思路:

(1)题意:
词语接龙,上一个词的最后一个字母和下一个词的第一个字母要相同。
(2)方法:
并查集+欧拉路+欧拉回路(有向图)。

  • 欧拉路:图连通,存在一个顶点的入度比出度大1,一个顶点的出度比入度大1,其他顶点入度与出度相等。
  • 欧拉回路:图连通,所有顶点入度与出度相等。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int tree[30];//并查集 
int indegree[30],outdegree[30];//入度出度集 
int vis[30];

int findroot(int x)//查找函数 
{
    if(tree[x]==x) return x;
    else
    {
        int tmp=findroot(tree[x]);
        tree[x]=tmp;
        return tmp;
    } 
}

void join(int x,int y)//合并函数 
{
    int fx=findroot(x);
    int fy=findroot(y);
    if(fx!=fy) tree[fy]=fx;
}

int main()
{
    int t,n;
    char company[1100];
    cin>>t;
    while(t--)
    {
        memset(indegree,0,sizeof(indegree));
        memset(outdegree,0,sizeof(outdegree));
        memset(vis, false, sizeof(vis));
        for(int i=0;i<30;i++)
        {
            tree[i]=i;
        }
        cin>>n;
        while(n--)
        {
            cin>>company;
            int len=strlen(company);//字符串长度
            //合并顶点 
            join(company[0]-'a',company[len-1]-'a');
            //入度加1 
            indegree[company[len-1]-'a']++;
            //出度加1 
            outdegree[company[0]-'a']++;
            vis[company[0]-'a']=true;
            vis[company[len-1]-'a']=true;
        }
        //ans判断图是否连通,tag为图中顶点入度不等于出度的个数 
        int ans=0,tag=0;
        //a为入度比出度大1的点的个数,b为出度比入度大1的点的个数
        int a=0,b=0;
        //判断是否连通 
        for(int i=0;i<30;i++)
        {
            if(vis[i]&&tree[i]==i) ans++;
        }
        //不连通,直接输出 
        if(ans>1) cout<<"The door cannot be opened."<<endl;
        else
        {
            //确定tag,a,b的值 
            for(int i=0;i<30;i++)
            {
                if(vis[i]&&indegree[i]!=outdegree[i]) tag++;
                if(vis[i]&&indegree[i]-outdegree[i]==1) a++;
                if(vis[i]&&outdegree[i]-indegree[i]==1) b++;
            }
            //tag=0存在欧拉回路 
            if(tag==0) cout<<"Ordering is possible."<<endl;
            //存在欧拉路径 
            else if(a==b&&a==1&&tag==2) cout<<"Ordering is possible."<<endl;
            else cout<<"The door cannot be opened."<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值