杭电1059(多重背包)

Dividing(难度:1)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output

For each colletcion, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

思路:

题意:两个人收集石头,按分类(价值)分成6类,并从1到6编号,第i号有ni个,价值为i,问是否能够按照价值将它们均分。

注意:总价值为偶数,也不一定可以均分,例:若有3块石头,价值分别为1,3,10,总价值为14,但也无法均分。

抽象:多重背包问题,因为每种石头的数量是固定的。

方法:

  • 算出总价值,若总价值为奇数,则不可以均分;
  • 若总价值为偶数,二进制转化为01背包问题,套模板。
  • 若各种石头价值的线性组合值能够为总价值的一半,就均分。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio> 

using namespace std;

#define maxn 100010

int w[10],dp[maxn];
int value[maxn];

int main()
{
    int sum,icase=0,count;
    while(cin>>w[1]>>w[2]>>w[3]>>w[4]>>w[5]>>w[6])
    {
        if(w[1]+w[2]+w[3]+w[4]+w[5]+w[6]==0) break;
        memset(dp,0,sizeof(dp));
        sum=count=0;
        for(int i=1;i<=6;i++)
        {
            sum+=w[i]*i;
            for(int j=1;j<=w[i];j<<=1)
            {
                value[count++]=j*i;
                w[i]-=j;
            }
            if(w[i]>0)
            {
                value[count++]=w[i]*i;
            }
        }
        cout<<"Collection #"<<++icase<<":"<<endl;
        if(sum%2!=0)//总价值为奇数,不能平分 
        {
            cout<<"Can't be divided."<<endl<<endl;
            continue;
        }
        sum/=2;
        for(int i=0;i<count;i++)
        {
            for(int j=sum;j>=value[i];j--)
            {
                dp[j]=max(dp[j],dp[j-value[i]]+value[i]);
            }
        }
        if(dp[sum]==sum) cout<<"Can be divided."<<endl<<endl;
        else cout<<"Can't be divided."<<endl<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值