杭电1059 Dividing

题目内容:

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.

题目大意:

对于给定的六种不同价值、数量marble,将其平均分给两人,判断是否能做到均分


题目分析:

这道题其实十分灵活,可以选择dp,背包等多种方法来解决,而我在不经意间用一种很水的方法过了…………不多说了上代码


题目代码:

#include<stdio.h>

int data[6];

int main()
{
    int order=0;
    while(scanf("%d%d%d%d%d%d",&data[0],&data[1],&data[2],&data[3],&data[4],&data[5])!=EOF)
    {
        int sum=0;
        int flag=0;
        if(data[0]+data[1]+data[2]+data[3]+data[4]+data[5]==0)
            break;
        order++;
        for(int i=0;i<6;i++)
        {
            data[i]%=20;
            sum+=data[i]*(i+1);
        }
        if(data[0]+data[1]+data[2]+data[3]+data[4]+data[5]==0)
            flag=1;
        if(sum%2==1)
            flag=0;
        else
        {
            int a,b,c,d,e,f;
            for(a=0;a<=sum/2&&a<=data[0];a++)
                for(b=0;a+b*2<=sum/2&&b<=data[1];b++)
                    for(c=0;a+b*2+c*3<=sum/2&&c<=data[2];c++)
                        for(d=0;a+b*2+c*3+d*4<=sum/2&&d<=data[3];d++)
                            for(e=0;a+b*2+c*3+d*4+e*5<=sum/2&&e<=data[4];e++)
                                for(f=0;a+b*2+c*3+d*4+e*5+f*6<=sum/2&&f<=data[5];f++)
                                    if(a*1+b*2+c*3+d*4+e*5+f*6==sum/2)
                                    {
                                        flag=1;
                                        break;
                                    }
        }
        if(flag==1)
            printf("Collection #%d:\nCan be divided.\n\n",order);
        else
            printf("Collection #%d:\nCan't be divided.\n\n",order);
    }
    return 0;
}
解题评价:

这道题由于数据比较水,因而用这种很水的方法也a掉了,但建议使用其他方法尝试重做,毕竟如果卡紧时间要求,水过是不可能的

当前水平评分:4

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值